Slower processing times

Incident Report for CFH Docmail

Resolved

The incident has now been resolved, thank you for your patience.
Posted Jul 27, 2026 - 11:40 BST

Investigating

We are currently experiencing slower than usual processing times at the moment. We are working across our teams to resume normal service as soon as possible. Thank you for your patience.
Posted Jul 27, 2026 - 09:07 BST
This incident affected: Web portal and PrintDriver.