Issue Resolved
Incident Report for
CFH Docmail
Resolved
We experienced an unexpected outage earlier today lasting approximately 30 minutes. The issue has now been fully resolved and services are operating normally. We apologise for any inconvenience this may have caused and thank you for your patience.
Posted
Aug
14
,
2025
-
11:30
BST
×
Subscribe to Incident
Subscribe to updates for
Issue Resolved
via . You'll receive .