Royal Mail international mail
Incident Report for CFH Docmail
Resolved
Royal Mail have resolved the issue and we have resumed sending internationally addressed mail through them.
Posted Jan 23, 2023 - 09:47 UTC
Update
Royal Mail are continuing to be affected by the cyber incident.

We are temporarily sending international items via an alternative carrier and there is a small additional surcharge for this which will be included in the price when proofing your item. You may notice no postal indicia on proofs for foreign addressed items during this period.

We apologise for any inconvenience this may cause you.
Posted Jan 17, 2023 - 09:35 UTC
Monitoring
Royal Mail have announced severe service disruption due to a cyber incident that is affecting international mail.

UK addressed mail is not affected.

If you have international items to send you can continue to submit these, we will be producing them as normal but holding them securely on site until the issue is resolved.

Royal Mail have advised that their IT teams are working on resolving the issue, however we will look into other options of sending this mail if it is not resolved within 48 hours.

We apologise for any inconvenience this may cause you.
Posted Jan 12, 2023 - 11:43 UTC